48 Port Switch D-Link DGS-1210-52 48-Port 10/100/1000 Base-Twith 4 SFP Smart Switch

Today’s Promotion ON  

BrandDLink
SWITCH48 ports
Report Abuse
Description

48 Port Switch D-Link DGS-1210-52 48-Port 10/100/1000 Base-Twith 4 SFP Smart Switch

48-Port 10/100/1000Base-T with 4 SFP Smart Switch

DGS-1210-52

Overview
The new DGS-1210-28P and DGS-1210-52 are the latest generation of D-Link Web Smart Switches featuring D-Link Green 3.0 technology. The switches comply with the IEEE 802.3az Energy Efficient Ethernet standard. Support for IPv6 management and configurations ensures your network remains protected after the upgrade from IPv4 to IPv6. By offering multiple management options, the DGS-1210-28P and DGS-1210-52 allow quick deployment, infrastructure expansion, and seamless upgrades. Targeting small and medium sized businesses, these Web Smart Switch provide functionality, security, and manageability for a fraction of the standard cost of ownership.

The DGS-1210-28P is a PoE Web Smart Switch that provides 24 10/100/1000 Base-T PoE ports with 4 Gigabit SFP ports. In addition to IEEE 802.3af compliance, ports 1-4 provide up to 30 watts of power output following IEEE 802.3at. The design allows more flexibility in power allocation for a variety of powered devices with affordable installation costs.

The DGS-1210-52 provides 48 10/100/1000 Base-T ports with 4 Gigabit SFP ports.

Energy Saving
The DGS-1210-28P and DGS-1210-52 are capable of conserving power without sacrificing operational performance or functionality by using D-Link Green 3.0 technology. Using the Energy Efficient Ethernet standard, the network will automatically decrease the power usage when traffic is low with no setup required. For environments not fully supporting the standard, these switches offer advanced power-saving settings including port shutoff and standby, LED shutoff, and system hibernation based on custom time profiles. The time profiles can also be applied to the DGS-1210-28P PoE switch so that unnecessary power consumption can be saved during off hours. The switches can also detect the length of connected cables to automatically reduce power usage on shorter cable connections.

Easy Management
The D-Link Web Smart Switch series is designed for easy management. All configurations can be made through a Web interface regardless of the host PC’s operating system. Furthermore, the web UI contains ten language options to make operations more straightforward. In the intial installation, the Smart Console Utility will automatically discover all D-Link Smart switches in the network, allowing administrators to assign IP addresses and subnet masks quickly. It also allows simultaneous firmware upgrades to multiple switches, saving a great deal of time. Important management commands, such as download firmware or configuration file, can be completed using batch
operations for multiple switches.

Auto Surveillance VLAN and Voice VLAN
The D-link Web Smart series automates the process of setting up IP surveillance and VoIP devices on a network. Auto Surveillance VLAN consolidates data and surveillance video transmission through the network, sparing businesses the expense of maintaining dedicated facilities. ASV also protects the quality of realtime video by grouping IP surveillance devices on a single high priority VLAN. This ensures that surveillance video streams will not be affected when ordinary data traffic is at a high level. Similarly, the Auto Voice VLAN guarantees clear quality and efficient transmission for all voice communication.

Extensive Layer 2 Features
Equipped with a complete lineup of L2 features, these switches include IGMP Snooping, Port Mirroring, Spanning Tree, and Link Aggregation Control Protocol (LACP). The IEEE 802.3x Flow Control function allows servers to directly connect to the switch for fast, reliable data transfer. At 2000 Mbps Full Duplex, the Gigabit ports provide high-speed data pipes to servers with minimum data transfer loss. Network maintenance features include Loopback Detection and Cable Diagnostics. Loopback Detection is used to detect loops created by a specific port and automatically shut down the affected port. The Cable Diagnostic feature designed primarily for administrators and customer service representatives, can rapidly discover the type of error and determine the cable quality.

Secure your Network
D-Link’s innovative Safeguard Engine protects the switches against traffic flooding caused by virus attacks. The switches also support 802.1X port-based authentication, allowing the network clients to be authenticated through external RADIUS servers. In addition, the Access Control List (ACL) feature enhances network security and protects the network by screening traffic from illegal MAC or IP addresses. ARP Spoofing Prevention prevents malicious intruders from sending massive fake ARP messages through a manipulated source. This protects important data from being stolen by Man-in-the-Middle attacks, and prevents wasting CPU cycles on these packets. For added security, the DHCP Server Screening feature blocks rogue DHCP server packets from user ports to prevent unauthorized IP assignment.

SPECIFICATION


General
Port Standards & Functions
• IEEE 802.3 10BASE-T Ethernet (twisted-pair copper)
• IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper)
• IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twisted-pair copper)
• Auto-negotiation
• IEEE 802.3x Flow Control
Number of Ports
• 48 10/100/1000 Mbps
• 4 Gigabit SFP
Network Cables
• UTP Cat.5, Cat.5e (100m max)
• EIA/TIA-568 100-ohm STP (100m max)
Full/Half Duplex
• Full/half duplex for 10/100Mbps speeds
• Full duplex for Gigabit speed
Media Interface Exchange
• Auto MDI/MDI-X adjustment for all twisted-pair ports
Performance
Switching Capacity
• 104 Gbps
Transmission Method
• Store-and-forward
MAC Address Table
• 16,000 entries per device
MAC Address Update
• Up to 256 static MAC entries
• Enable/disable auto-learning of MAC addresses
Maximum 64 bytes packet forwarding rate
• 77.4 Mpps
Packet Buffer Memory
• 1 MB per device
Physical and Environmental
AC Input
• 100 to 240 VAC 50/60Hz internal universal power supply
Maximum Power Consumption
• 43.5W
Standby Power Consumption
• 20.7W/110V, 22W/240V
Fan Quantity
• Two smart fans
Acoustics
• 47.1 dB(A)
Heat Dissipation
• 148.42 BTU/hr.
Operating Temperature
• 41° to 122°F (-5° to 50°C)
Storage Temperature
• -4° to 158°F (-20° to 70°C)
Operating Humidity
• 0% to 95% non-condensing
Storage Humidity
• 0% to 95% non-condensing
Dimensions
• 17.32 x 9.84 x 1.73 inches; (440 x 250 x 44 mm)
• 19-inch standard rack mounting width, 1U height
Weight
• 9.0 lbs (4.1kg)
Diagnostic LEDs
• Power (per device)
• Link/Activity/Speed (per 10/100/1000Mbps port)
• Link/Activity (per SFP port)
• Fan (per device)
MTBF
• 201,517 hours
Certifications
• FCC Class A
• CE Class A
• ICES-003
• VCCI Class A
• C-Tick
• BSMI
Safety
• cUL
• CE LVD
Software Features
L2 Features
• MAC Address Table
   • 16,000 entries
• Flow Control
   • 802.3x Flow Control
   • HOL Blocking Prevention
• IGMP Snooping
   • IGMP v1/v2 Snooping
   • Supports 256 IGMP groups
   • Supports at least 64 static multicast addresses
   • IGMP per VLAN
   • Supports IGMP Snooping Querier
• Spanning Tree Protocol
   • 802.1D STP
   • 802.1w RSTP
• 802.3ad Link Aggregetion
   • DGS-1210-28P:  Max. 14 groups per device/8 ports per group
   • DGS-1210-52:  Max. 26 groups per device/8 ports per group
• Port Mirroring
   • One-to-One, Many-to-One
   • Supports Mirroring for Tx/Rx/Both
• Multicast Filtering
   • Forwards all unregistered groups
   • Filters all unregistered groups
• LLDP, LLDP-MED
VLAN
• 802.1Q
• VLAN Group
   • Max 256 static VLAN groups
   • Max 4094 VIDs
• Management VLAN
• Asymmetric VLAN
• Auto Voice VLAN
   • Max. 10 user defined OUI
   • Max. 8 default OUI
• Auto Surveillance VLAN
QoS (Quality of Service)
• 802.1p Quality of Service
• 4 Queues per port
• Queue Handling
   • Strict
   • Weighted Round Robin (WRR)
• CoS based on
   • 802.1p Priority Queues
   • DSCP
   • ToS1
• Bandwidth Control
   • Port-based (Ingress/Egress, min. granularity 64 Kb/s)
Access Control List
• DGS-1210-28P:
   • Max. 50 profiles
   • Max. 240 rules shared by profiles
   • Single or multiple ports (each rule)
• DGS-1210-52:
   • Max. 50 profiles
   • Max. 450 rules shared by profiles
• ACL based on
   • MAC Address
   • IPv4 Address (ICMP/IGMP/TCP/UDP)
   • 802.1p Priority
   • DSCP
   • Ethertype
• ACL Actions
   • Permit
   • Deny
Security
• Port Security
   • Supports up to 64 MAC addresses per port
• Broadcast/Multicast/Unicast Storm Control
• Static MAC
• D-Link Safeguard Engine
• DHCP Server Screening
• Trusted Host
• ARP Spoofing Prevention
   • Max. 64 entires
• SSL
   • Supports v1/v2/v3
   • Support IPv4/IPv6
• Traffic Segmentation
• Smart Binding
   • Supports 512 entires of IP-MAC-Port binding
   • Discover connected devices and click to bind
   • Inspect ARP packets and/or IP packets
   • Supports DHCP Snooping
AAA
• 802.1X Port-based Authentication
   • Supports RADIUS Server
   • Supports EAP, OTP, TLS, TTLS, PEAP
OAM
• Cable Diagnostics
• Factory Reset
MIB
• 1213 MIB II
• 1493 Bridge MIB
• 1907 SNMP v2 MIB
• 1215 Trap Convention MIB
• 2233 Interface Group MIB
• D-Link Private MIB
• Power-Ethernet MIB
• LLDP MIB
RFC
• RFC 783 TFTP
• RFC 854 Telnet Server
• RFC 951 BootP/DHCP Client
• RFC 1157 SNMP v1, v2c, v3
• RFC 1213 MIB II, IF MIB
• RFC 1215 MIB Traps Convention
• RFC 1350 TFTP
• RFC 1493 Bridge MIB
• RFC 1542 BootP/DHCP Client
• RFC 1769 SNTP
• RFC 1901 SNMP v1, v2c, v3
• RFC 1907 SNMP v2c MIB
• RFC 1908 SNMP v1, v2c, v3
• RFC 2068 FCS
• RFC 2131 BootP/DHCP Client
• RFC 2138 RADIUS Authentication
• RFC 2139 RADIUS Authentication
• RFC 2233 Interface Group MIB
• RFC 2246 SSL
• RFC 2475
• RFC 2570 SNMP v1, v2c, v3
• RFC 2575 SNMP v1, v2c, v3
• RFC 2598 CoS
• RFC 2616 FCS
• RFC 2618 RADIUS Authentication
• RFC 2819 RMON v1
• RFC 2865 RADIUS Authentication
• RFC 3164 System Log
• RFC 3195 System Log
• RFC 3411-17 SNMP
• RFC 3621 Power Ethernet MIB
Management
• Multi-Language Web-based GUI
   • English (default)
   • Simplified Chinese
   • Traditional Chinese
   • French
   • German
   • Italian
   • Japanese
   • Portuguese
   • Russian
   • Spanish
• SmartConsole Utility
• Simplified CLI
• Telnet Server
• TFTP Client
• Configurable MDI/MDIX
• SNMP
   • Supports v1, v2c, v3
• SNMP Trap
• System Log
   • Max. 500 log entries
• BootP/DHCP Client
• SNTP
• ICMPv6
• IPv4/v6 Dual Stack
• DHCP Auto Configuration
• RMON v1
• Time-based PoE (DGS-1210-28P only)
D-Link Green 3.0 Technology
• Power Saving by:
   • Link Status
   • Cable Length detection
   • LED or Port Shutoff
   • Port Standby mode
   • System Hibernation mode
Ordering Information
• DGS-1210-28P  Web Smart 24-Port Gigabit PoE Switch with 4 Gigabit SFP ports
• DGs-1210-52  Web Smart 48-Port Gigabit Switch with 4 Gigabit SFP ports
Optional Products
Optional SFP Transceivers
• DGS-712 1000BASE-T Copper
• DEM-310GT 1000BASE-LX, Single-mode, 10 km
• DEM-311GT 1000BASE-SX, Multi-mode, 550 m
Optional Software
• DV-600S D-View 6.0 Network Management System (Standard Edition)
• DV-600P D-View 6.0 Network Management System (Professional Edition)

Today’s Promotion ON  

Shipping
Reviews (0)

Reviews

There are no reviews yet.

Be the first to review “48 Port Switch D-Link DGS-1210-52 48-Port 10/100/1000 Base-Twith 4 SFP Smart Switch”
Questions & Answers
Loading...
Shipping & Delivery

Efficient Shipping and Delivery

At System Plus Ltd, we take great pride in providing a seamless and efficient shipping and delivery experience for our valued customers. Once you've placed your order, we understand the importance of receiving your tech products promptly. That's why we offer a range of shipping options to suit your needs, from standard delivery to expedited shipping for those who can't wait to get their hands on the latest technology. Rest assured that we partner with trusted shipping carriers to ensure the safe and timely delivery of your items.

Transparency

We also understand that transparency is key when it comes to online shopping. As a result, we provide detailed tracking information for your orders, so you can monitor the progress of your shipment every step of the way. Our dedicated customer support team is available to assist you with any questions or concerns regarding your delivery, ensuring that your shopping experience with us is not only convenient but worry-free. Shop with confidence at our e-commerce store, knowing that your orders will be handled with care and delivered to your door as efficiently as possible.

 
 
 

 

More Products

Samsung refrigerator 415LT/ DIGITAL INVERTER FRIDGE +20 years warranty

TODAY 'S PROMOTION: ON

415 L Twin Cooling Plusâ„¢ Double Door Refrigerator

RT42B5468SL

Choose colour

Colour : Real Stainless

AMION Electric Kettle (AM 181 LK)

BrandAMION
ColourSilver
Special FeatureBoil Dry Protection, Automatic Shut Off
Package InformationKettle
Product Dimensions15L x 5W x 10H Centimeters
Wattage1500 Watts
Included ComponentsKettle
Product Care Instructions

 

Contact Us For Price!

Today's Promotion: On

✅ Contact for Latest Price

HUAWEI Mate X6

HUAWEI Mate X6

HUAWEI Mate X6
  • Nebula Red
  • Black
  • Nebula Gray
Nebula Red, Black, Nebula Gray
  • Height

    156.6 mm

    Width

    Folded: 73.78 mm

    Unfolded: 144.04 mm

    Depth

    Folded: 9.85 mm (Vegan Fiber) /9.9 mm (Vegan Leather)

    Unfolded: 4.6 mm

    *Product size, product weight, and related specifications are theoretical values only. Actual measurements between individual products may vary. All specifications are subject to the actual product. Folded thickness does not include the appearance of the camera module. Unfolded thickness does not include screen borders.

    **The actual dimensions may vary depending on the configuration, manufacturing process, and measurement method.

    Weight

    Approx. 239 g (including battery)

    *The claimed weight does not include the weight of the outer screen protective film and the inner screen surface layer.

    **The actual weight may vary slightly according to configuration, manufacturing process, and measurement method.

  • Size

    Main Screen: 7.93 inches

    Cover Screen: 6.45 inches

    *The diagonal length of the cover screen is 6.45 inches and the diagonal length of the main screen is 7.93 inches, when each is measured as a standard rectangular, rather than the rounded-corner shape seen on both displays (actual viewing area is slightly smaller).

    Colour

    Main Screen: 1.07 billion colours

    Cover Screen: 1.07 billion colours

    Type

    Main Screen: OLED, 1-120 Hz LTPO adaptive refresh rate, 1440 Hz high frequency PWM dimming

    Cover Screen: OLED, 1-120 Hz LTPO adaptive refresh rate, 1440 Hz high frequency PWM dimming

    Resolution

    Main Screen: 2440 × 2240 Pixels

    Cover Screen: 2440 × 1080 Pixels

    *This resolution corresponds to the standard rectangle. The actual number of effective screen pixels is slightly less.

    PPI

    Main Screen: 417 PPI

    Cover Screen: 413 PPI

  • EMUI 15.0

  • RAM + ROM

    12 GB RAM + 512 GB ROM

    *The available memory capacity is less than this value because the system software occupies some space.

    External Memory Support

    Not supported

  • 50 MP Ultra Aperture Camera (F1.4-F4.0, RYYB, OIS)

    40 MP Ultra-Wide Angle Camera (F2.2, RYYB)

    48 MP Telephoto Macro Camera (F3.0, RYYB, OIS)

    1.5 M Spectral Channels Ultra Chroma Camera

    *In different modes, the number of photo and video pixels may be slightly different, please refer to the actual situation.

    Autofocus Mode

    Phase focus, Contrast focus

    Zoom Mode

    Supports 4x optical zoom (4x zoom is approximate, focal length of lens are 24 mm, 13 mm, 90 mm)

    100x digital zoom

    *In different modes, the number of pixels may be slightly different, please refer to the actual situation.

    Image Resolution

    Up to 8192 × 6144 pixels

    *In different photo modes, the number of photo pixels may be slightly different, please refer to the actual situation.

    Video Resolution

    Up to 3840 × 2160 pixels

    *In different video modes, the number of video pixels may be slightly different, please refer to the actual situation.

    Rear Flashlight

    LED Flash

    Rear Camera Capture Mode

    AI Moving Picture, Ultra Speed Snapshot, Night, Super Macro, Macro video,High-res,Time-Lapse,Ultra Wide Angle Lens,Adjustable Physical Aperture,  Portrait, Pro,Slow-Mo, Panorama, Light painting,  Filter, Stickers, Master AI,Capture Smiles, Audio Control,Timer, Burst Shooting

  • Folded: 8 MP Camera (F2.4 aperture)

    Unfolded: 8 MP Camera (F2.2 aperture)

    *In different modes, the number of photo and video pixels may be slightly different, please refer to the actual situation.

    Image Resolution

    Up to 3264 × 2448 pixels

    *Photo pixels may vary in different shooting modes, please refer to the actual situation.

    Video Resolution

    Up to 3840 × 2160 pixels

    *Video pixels may vary in different shooting modes, please refer to the actual situation.

    Front Camera Capture Mode

    Moving Picture,Portrait, Time-Lapse, Filter, Capture Smiles, Mirror Reflection, Audio Control, Timer

  • 5110 mAh (typical value)

    *The Battery Rated Capacity is 4990 mAh.

    **Typical value. Actual capacity may vary slightly.
    This capacity is the nominal battery capacity. The actual battery capacity for each individual phone may be slightly above or below the nominal battery capacity.

    ***Non-removable battery. Removing the battery may cause damage to the device. To replace or repair the battery, please visit an authorized HUAWEI Service Centre.

  • HUAWEI SuperCharge (Max 66 W)

    The phone supports 11V/6A (Max 66 W) super-fast charging and is compatible with 10V/4A or 10V/2.25A or 4.5V/5A or 5V/4.5A super-fast charging, and 9V/2A fast charging.

    *Support a maximum of 66 W Huawei wired SuperCharge, and needs to be used with 66 W or higher Huawei SuperCharge package. Whether the charging kit needs to be purchased separately depends on the actual packing list.The actual charging power varies depending on the scenario.

    Wireless HUAWEI SuperCharge (Max 50 W)

    *Need to purchase the HUAWEI SuperCharge Wireless Charger Stand (Max 50 W / 80 W) or HUAWEI SuperCharge Wireless Car Charger (Max 50 W / 80 W), and used with dedicated HUAWEI 66 W or 88 W or 100 W Power Adapter. The actual charging power varies depending on the scenario.

  • IPX8

    *This product is rated as IPX8 for splash and water under IEC standard 60529 and was tested under controlled laboratory conditions.

    **Splash and water are not permanent conditions and resistance may decrease over time with normal use. Do not charge the phone when it is wet or in moist environments. Refer to the manual for cleaning and drying instructions. Submersion in liquid and the resulting damage is not covered by the warranty.

    ***IPX8 rating means that based on certain defined test conditions, the device is protected against harmful ingress of static water at up to 2.0 meters, for up to 30 minutes, meanwhile the temperature difference between water and device is not more than 5°C.

  • Single SIM model
    Primary SIM Card

    ICL-LX9 (Single SIM model)

    4G LTE FDD: Bands

    1 / 2 / 3 / 4 / 5 / 6 / 7 / 8 / 9 / 12 / 17 / 18 / 19 / 20 / 26 / 28 / 66

    4G TD-LTE: Bands 34 / 38 / 39 / 40 / 41 / 42

    3G WCDMA: Bands 1 / 2 / 4 / 5 / 6 / 8 / 19

    2G GSM: Bands 2 / 3 / 5 / 8 (1900 / 1800 / 850 / 900 MHz)

    *Functions available on the live network depend on the situations of carrier's network and related services deployment.

    Secondary SIM Card

    Not Supported

    Dual SIM model
    Primary SIM Card

    ICL-LX9 (Dual SIM model)

    4G LTE FDD: Bands

    1 / 2 / 3 / 4 / 5 / 6 / 7 / 8 / 9 / 12 / 17 / 18 / 19 / 20 / 26 / 28 / 66

    4G TD-LTE: Bands 34 / 38 / 39 / 40 / 41 / 42

    3G WCDMA: Bands 1 / 2 / 4 / 5 / 6 / 8 / 19

    2G GSM: Bands 2 / 3 / 5 / 8 (1900 / 1800 / 850 / 900 MHz)

    *Functions available on the live network depend on the situations of carrier's network and related services deployment.

    Secondary SIM Card

    4G LTE FDD: Bands

    1 / 2 / 3 / 4 / 5 / 6 / 7 / 8 / 9 / 12 / 17 / 18 / 19 / 20 / 26 / 28 / 66

    4G TD-LTE: Bands 34 / 38 / 39 / 40 / 41 / 42

    3G WCDMA: Bands 1 / 2 / 4 / 5 / 6 / 8 / 19

    2G GSM: Bands 2 / 3 / 5 / 8 (1900 / 1800 / 850 / 900 MHz)

    *Functions available on the live network depend on the situations of carrier's network and related services deployment.

  • WLAN

    2.4 GHz and 5 GHz

    802.11 a/b/g/n/ac/ax, 2 × 2 MIMO, HE160, 1024 QAM, 8 Spatial-stream Sounding MU-MIMO

    *Need to be used with the corresponding router.

    Bluetooth

    Bluetooth 5.2, Support BLE, SBC, AAC, LDAC and L2HC.

    USB

    USB Type-C, USB 3.1 GEN1

    *This function should be used with the USB cable (non-standard USB cable, need to be purchased separately) that supports this function.

    **The inbox USB cable supports USB 2.0.

    Earjack

    USB Type-C earjack

    *Support Type-C digital headset.

  • Read Write mode/Card Emulation mode (payment by SIM card, or HCE) is supported.

    *The SIM card used for SIM card payment can only be inserted into the SIM1 card slot.

  • GPS (L1 + L5 Dual band)/AGPS/GLONASS/BeiDou (B1I + B1C + B2a + B2b Quad-band)/GALILEO (E1 + E5a + E5b Tri-band)/QZSS (L1 + L5 Dual band)/NavIC

  • Gesture Sensor

    Gravity Sensor

    Barometer

    Infrared Sensor

    Fingerprint Sensor

    Hall Sensor

    Gyroscope

    Compass

    Ambient Light Sensor

    Proximity Sensor

    Laser Sensor

    Colour Temperature Sensor

  • Audio

    Huawei Histen, support stereo sound

    *.mp3,*.mp4,*.ogg,*.amr,*.aac,*.flac,*.wav,*.3gp,*.midi

    Video

    *mp4,*3gp

  • Phone (Built-in battery) × 1

    Charger × 1 (Dependent on market)

    USB Type-C Cable × 1 (Dependent on market)

    Rotating Stand PU Case × 1

    Quick Start Guide × 1

    Eject Tool × 1

    Warranty Card × 1 (Dependent on market)

    Precautions card × 1

    Outer Screen Protective Film (attached to the phone) × 1

    *Contact the sales channel for a more detailed list.

    *May vary in different market. Subject to the actual product.

    specifications, and features, HUAWEI may make real-time adjustments to the preceding specifications, so that they match the product performance, specifications, indexes, and components of the actual product. Product information is subject to such changes and adjustments without notice.

APC NetShelter AR3100 SX 42U 600mm Wide x 1070mm Deep Enclosure with Sides Black

APC NetShelter AR3100 SX 42U 600mm Wide x 1070mm Deep Enclosure with Sides Black

  • Standard enclosure for low to medium density server and networking applications.
  • Compact width to optimize data center space. 42U height to easily roll through doorways.
Note: Products with electrical plugs are designed for use in the US. Outlets and voltage differ internationally and this product may require an adapter or converter for use in your destination. Please check compatibility before purchasing.

Today’s Promotion ON

NOBEL-NDF8G NOBEL DEEP FRYER STAINLESS STEEL 4 LITRES 2500-3000W STAINLESS STEEL

NOBEL-NDF8G NOBEL DEEP FRYER STAINLESS STEEL 4 LITRES 2500-3000W STAINLESS STEEL

  • 4 Litre Capacity
  • Detachable Enamel Oil Tank
  • Dishwasher Safe
  • 2500W - 3000W
  • Stainless Steel Decor
  • Light Indicator, Single Knob Control
  • Plastic Handle on Both Sides of Body
  • Dishwasher Safe
  • Silver & Black Color
  • 220-240V~, 50-60Hz
  • Product Dimensions: 348 x 246 x 267 (W x D x H) mm
  • Packaging Dimensions: 480 x 290 x 642 (W x D x H) mm
  • 4.05 Kgs Gross Weight
  • 3.12 Kgs Net Weight

    ✅ Contact for Latest Price

Zone 300

Zone 300
The essential wireless headset with great audio that gives you the freedom to move and stay connected.

Technical Specifications

Microphone
  • Type: Dual beamforming mics with noise-canceling algorithms
  • Frequency Response: 100-7KHz
Speakers
  • Frequency response (music mode): 50-20KHz
  • Frequency response (talk mode): 100-7KHz
  • Sensitivity: 96dB ±3dB @1kHz
  • Driver size: 1.18 in (30 mm)
  • Audio compliance: EN 50332-2 compliant

Today's Promotion: On

Contact Us For Price!

✅ Contact for Latest Price

Product Enquiry

Product Enquiry